I guess we could have an enum for that and it's just another field in ValidatorResult. So not too hard to add. Maybe some interface for setting it looks like:
Which means it's an error for the first one, and a warning only if it's the second one that doesn't match.
Probably a fairly small addition. What do you think?